Actualizar el CMS: ¿realmente es necesario?

WordPress 3.9 está disponible. Por favor, actualiza ahora”. Tras la irrupción de un aviso de este tipo, surge un dilema generalizado: ¿realmente es necesario hacerlo? La respuesta es SÍ. Al menos, si se quieren evitar ataques de hackers, corregir errores del software o bugs, y contar con las últimas funcionalidades del CMS (Sistema de Gestión de Contenidos) utilizado.

Los CMS (WordPress, Joomla, Drupal,Prestashop, Magento…) están en continuo desarrollo y cada vez que se producen modificaciones o mejoras en el sistema, se pone a disposición de los usuarios una nueva actualización.

Al ser sistemas libres y gratuitos son también más fáciles de hackear, sobre todo, las versiones antiguas, mucho más vulnerables a ataques externos. Actualizar la versión utilizada, recurrir a claves seguras y usar un plugin de seguridad, son las principales vías para evitar ataques.

En los últimos tiempos, ha habido una constatación de que los ataques contra los servidores de estos CMS han ido a más. Por lo tanto, no es obligatorio, pero lo ideal es ir actualizando las versiones  porque las últimas son siempre -se supone- las más seguras y protegidas, y las mejores en cuanto a funcionalidades.

Ahora bien, hay que tener en cuenta que al actualizar el sistema puede dejar de funcionar algún plugin. Sencillamente, hay que ver cuál falla y actualizarlo. O ver antes de actualizar si los plugins instalados funcionan con la nueva versión.

Eso sí, si alguien teme arrepentirse, tiene que saber que podrá restaurar la versión anterior tal cual si ha hecho previamente un backup.

Lo mejor siempre es hacer una copia de la web y probar las actualizaciones sobre la copia.

Lo importante es saber qué se gana y qué se pierde con la actualización. Pero hacerle caso omiso al aviso de actualización puede tener consecuencias muy negativas.

 

Ez dago iruzkinik

Iruzkin bat argitaratu